Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

[SOLVED] Admin system escaping characters showing /n/t

Go to End

8 Posts   2055 Views


Community Member, 151 Posts

23 January 2014 at 2:07am

Hi everyone

Attached is a picture of an admin system that works 100% fine locally, but when put onto production server it shows hundreds of /n/n/t/t

Now I have about 30 over instances of SS3 running on that server fine, so I just can't figure out why?

Any ideas?



Attached Files

Forum Moderator, 1391 Posts

23 January 2014 at 7:25am

Reloading the cms at that point might give you a better clue. For me that always happens when I had added an echo somewhere and forgot to remove it... So some unwanted output somewhere?

El Mich

Community Member, 8 Posts

24 January 2014 at 6:40am

Edited: 24/01/2014 6:40am

Try checking your _config.php files for whitespace before opening php tag. I vaguely remember having that same issue...


Community Member, 151 Posts

24 January 2014 at 10:25pm

White space did it at the start of one of my php files within mysite/code.


El Mich

Community Member, 8 Posts

24 January 2014 at 10:53pm

Glad to be of help.
Maybe this is something that could be mentioned somewhere in the config docu, since it's a hard one to track down.
Care to make a ticket?


Community Member, 5 Posts

12 August 2015 at 8:56am

Hi all.

Here's my two cents worth: I am using SS 3.1.13. I include the closing ?> tag along with the opening <?php tag since it just doesn't feel right to leave tags open, anywhere! I had white space AFTER my closing tags and removing this solved the OP's problem for me.


Community Member, 419 Posts

13 August 2015 at 2:52am

Edited: 13/08/2015 2:53am

It's a PHP file, not an HTML file.
Don't think of it as not closing PHP mode, think of it as never opening a direct output (ie. html) mode.

This kind of issue is often caused by characters in direct ouptut - often zero width ones, which can be a real problem to track down. It's safer (and more natural) to simply just not use ?>


Community Member, 5 Posts

23 October 2015 at 11:11am

Edited: 23/10/2015 11:13am

Thanks Pyromanik....

I'm not sure about it being "more natural" to leave out the closing tags, but I do see the error of my ways :)

Now, all I need to do is set up my editor to not automatically put in the closing ?> and break my bad habit!