Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

Blog Module /

Discuss the Blog Module.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Blog modue problems, /admin won't load anymore

Go to End

4 Posts   1727 Views


Community Member, 20 Posts

21 May 2011 at 11:00pm

Hi all,

I'm using a Silverstripe 2.4.0 install that has run more or less OK for some time now. Here is the site in question:

Today I tried to add a blog entry to the "Aktuelles" section's blog holder. As it happens, I accidentally double-clicked the "create" button after selecting "BlogEntry" as a page type, and oddly, inside the blog holder, a normal page appeared. After trying to erase it, then I was unable to erase or edit the old, original blog entry I had just typed in. I tried to re-enter the entry in a new post and erase the old one, but nothing worked -- the "delete from site" buttons on the bottom right simply didn't appear.

So I decided to try and go hunting in the database, and found the db entries relevant to the entry I wanted to erase, and deleted them, finding them based on timestamp and RecordID number. However, after that the /admin page won't load anymore -- no error message, just stays stuck at "Loading...". I tried running /dev/build?flush=1, but to no avail.

Any ideas? Is there a painless way to get the page data out and reinstall it in a new version, or to fix the database?

Thanks for any help you can offer in advance.


Community Member, 20 Posts

21 May 2011 at 11:02pm

Addendum: Using Firefox 4 and Chrome 11 on Mac OS X 10.6, for what it's worth.


Community Member, 20 Posts

21 May 2011 at 11:11pm

Ummm...for other reasons, I quite Chrome and restarted it, and now the Admin page loads again. No idea why...I know for a fact that I did a force-reload on the page, so it shouldn't be a browser cache problem.

So now I'm back to the beginning, where the old, incorrect blog entry is visible in the page tree, but crossed out in red. But I can't do anything to remove it. If I click on it, the buttons at the bottom right don't appear, and the content appears empty. Since the page isn't visible on the site, it's not that big a deal, but still annoying...any ideas on how to remove it? At least under all the Blog* tables, there shouldn't be anything related to that post left, but it still shows up.


Community Member, 130 Posts

26 May 2011 at 7:08am

Hi, Fairfax71,

When you deleted the entry from the db did you delete it from sitetree and sitetree_live? I think you need to delete both.