Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

Hosting Requirements /

What you need to consider when choosing a hosting provider and plan.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

SS 3.6.1 assets directory keeps returning to incorrect permissions.

Go to End



Community Member, 60 Posts

26 September 2017 at 6:25pm

I have a site that worked perfectly on its dev server and then moved to its production server, the assets directory keeps getting its file permissions changed back. Causing 403 errors for uploads (ie I change the permissions and some time later they get reset).

The webhost ran up another clean install of SS3.6.1 on the same server and it had the same problem. You can not upload images etc.

The server is currently running:

SilverStripe 3.6
Apache 2.2 current patch
PHP 5.4.5 current security patch
MySQL 5.5.57 current patch
FreeBSD 10.3 current patch

The host thought they had fixed it by adding:

umask (022);

To the top of framework/main.php, however this has allowed files to upload through the CMS, but it still shows a 403 error on the front end.

Never had this issue with getting SS to work on a server before, so wondering if anyone else has encountered it and what you did to rectify it.