Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

[SOLVED] SS3 installation error: [Warning] is_readable(): open_basedir restriction in effect

Go to End

23 Posts   26820 Views

Optic Blaze

Community Member, 190 Posts

7 July 2012 at 2:09am

Hi there, i am trying install SS3 for the first time. I get the following error.
Any help is appreciated:

[Warning] is_readable(): open_basedir restriction in effect. File(/usr/share/pear/Zend/Translate/Adapter/I18nRailsYamlAdapter.php) is not within the allowed path(s): (/usr/wwws/users/opticb:/usr/www/users/opticb:/usr/home/opticb:/usr/local/rmagic:/usr/www/users/he/_system_:/usr/share/php:/usr/local/lib/php:/tmp:/usr/bin:/usr/local/bin:/usr/local/share/www:/usr/share/misc)
GET /customers/ss3/dev/build?returnURL=%2Fcustomers%2Fss3%2F

Line 198 in /usr/www/users/opticb/customers/ss3/framework/thirdparty/Zend/Loader.php

190 foreach (self::explodeIncludePath() as $path) {
191 if ($path == '.') {
192 if (is_readable($filename)) {
193 return true;
194 }
195 continue;
196 }
197 $file = $path . '/' . $filename;
198 if (is_readable($file)) {
199 return true;
200 }
201 }
202 return false;
203 }


Community Member, 4 Posts

10 July 2012 at 9:19pm

If you have access to your php.ini change



Optic Blaze

Community Member, 190 Posts

10 July 2012 at 9:43pm

Edited: 26/10/2012 8:35am

Thanx, tried it but it did not work

I did not have access to php.ini but i managed to change the .htaccess file by adding the following to the top:

php_value safe_mode "0"
php_value open_basedir "0"

But the problem is that the shared host does not allow me to make changes to open_basedir with .htaccess


Forum Moderator, 1391 Posts

18 July 2012 at 4:51am

Your local spammer has been removed :)


Community Member, 2 Posts

30 August 2012 at 8:18am


Unfortunately it doesn't work for me.
I changed php.ini, deleted _config.php and reinstalled ... and nothing.
No tables are created in the database.



Community Member, 2 Posts

30 August 2012 at 9:07am

Ok. After one hour I checked mainpage again and it works.


Optic Blaze

Community Member, 190 Posts

25 October 2012 at 11:24pm

Ok spoke to my hosting company. Seems they make use of Zend Gaurd which does not set Zend up as part of PEAR but as a php library item. How do i get Silverstripe to load the library as /usr/share/php as apposed to /usr/share/pear ??

I tried switching open_basedir off...but the host does not allow this for security reasons and i dont have access to php.ini or httpdconf


Administrator, 25 Posts

26 October 2012 at 7:19am


Go to Top